Thread

Upgrade from EE2.x to 3.x database error

July 26, 2017 5:31pm

Subscribe [3]
  • #1 / Jul 26, 2017 5:31pm

    Sean C. Smith's avatar

    Sean C. Smith

    3818 posts

    I’ve followed all the steps in the guide to updating from EE2 to EE3 and when I tried to trigger the update by hitting the CP I get the following error:

    Exception Caught
    
    You must define the following database parameters: database
    
    /path/to/system/ee/EllisLab/ExpressionEngine/Service/Database/DBConfig.php:157

    double checked that config.php and database.php have been copied to system/user/config have also changed dbdriver to mysqli

    Please advise.

  • #2 / Oct 15, 2017 1:54am

    travisb

    168 posts

    I know it’s been a while, but… did you ever figure the cause of this error?

  • #3 / Oct 23, 2017 8:41pm

    travisb

    168 posts

    For me the problem was an overlooked file permission issue: database.php was set as too restricted.

  • #4 / Oct 25, 2017 7:49pm

    Derek Jones's avatar

    Derek Jones

    7176 posts

    Curious, was it not even readable by PHP? Write permissions on that file should be optional, ExpressionEngine just needs to be able to read it in order to copy them over to the config file (v3 doesn’t use a separate file for database config).

  • #5 / Oct 26, 2017 2:30pm

    travisb

    168 posts

    Deployed files and folders were fine, but some that were manually uploaded via sftp were converted from 666 to 664 on upload and that lead to the error on install / update. Don’t remember all files that had incorrect permissions, but sure that database.php was one. Haven’t had time to find why sftp permission conversion, but will track that down eventually.

ExpressionEngine News

#eecms, #events, #releases