Thread

"File Upload" button missing from modal on entry custom field

July 31, 2016 1:13am

Subscribe [2]
  • #1 / Jul 31, 2016 1:13am

    NMG

    7 posts

    I am not certain what is causing the “File Upload” button to be missing when invoking it on the entry custom fields. So I do not have access to upload directly with the modal window.

    When I use the File Manager through the control panel section “FILES” it shows up and everything works as expected. Anyone knows what might the issue be?

    I have System Admin permissions and I can’t figure out why the button is missing on the modal window on the entries form. I have tried with custom fields File field type, with Rich Text Editor and with Wygwam, but it is not working on any of these fields. If there are images already uploaded through the File Manager CP, those do show up, and I can select any of those items, but I can’t upload directly from that modal.

    I am attaching screen shots of it working from the CP and then not present in the modal window. Notice the missing upload file button on the modal.

    Thank you in advance with any help.

    Ludvik

  • #2 / Aug 03, 2016 1:58pm

    I have the same problem. The file modal needs to have a specific upload directory selected first. So, in the upper left, under the “All Files” title, select the directory filter and then you will see the upload button in the bottom left.

    I don’t have this problem with a file field. But when using Wygwam, it doesn’t seem to automatically select the directory I have it limited to.

  • #3 / Aug 05, 2016 2:22am

    NMG

    7 posts

    Thank you, that worked. The behavior is unexpected or not intuitive. It would be great to show the button, then ask where to upload.

    Thanks once again for the solution.

  • #4 / Feb 07, 2017 12:40pm

    Clearpeak's avatar

    Clearpeak

    413 posts

    Yes, I agree. It would be nice to allow the user to upload to any directory as in version 2.

    Thanks

ExpressionEngine News

#eecms, #events, #releases