ExpressionEngine CMS
Open, Free, Amazing


This is an archived forum and the content is probably no longer relevant, but is provided here for posterity.

The active forums are here.

Grid Field Type, Authorization

July 16, 2014 3:17pm

Subscribe [5]
  • #1 / Jul 16, 2014 3:17pm


    3 posts


    I think I’ve run into a peculiar bug that I can’t wrap my head around. I’ll note in advance this is a fresh EE 2.9.0 installation with no third party modules and that this error is occurring as a Super Admin in the Control Panel.

    I noticed that when attempting to post into a channel with a Grid Field Type that I get the following error:

    “You are not authorized to perform this action”

    This error only occurs when there are rows in the Grid Field for the new Channel post; meaning if I don’t add any rows, the post is successful and once I add a row, it fails. I tried with multiple columns (multiple fields per row) or just a single column (single field); neither attempt worked. I also tried to see if it had to do with specific field types in the Grid, but that didn’t fix the problem either when I tried different ones.

    I tried fiddling with some of the security settings, like whether it was using Session or Cookies only; that didn’t seem to fix it. I also disabled the requirement to have an IP and User Agent data, that failed to fix it as well.

    Any thoughts? I’m sure I can fix it myself by taking a look at the files directly if it’s a genuine bug, but I was hoping someone here can elucidate so that wasn’t necessary (e.g. I’m hoping it’s a minor oversight and didn’t require me to hack at anything).

    Thank you in advance for any help you can offer.

  • #2 / Jul 17, 2014 2:02am

    Simple IM's avatar

    Simple IM

    2 posts

    Getting the same error here with 2.9 after upgrading from 2.8.1…

    EDIT: Turns out if you replace the grid fieldtype with the 2.8.1 version it fixes this bug, if you need it working asap.

  • #3 / Jul 17, 2014 8:18am


    3 posts

    Thanks Simple; will try that until a permanent fix comes up as it sounds like a minor bug with 2.9. I appreciate it.

  • #4 / Jul 17, 2014 8:27am

    John Macpherson's avatar

    John Macpherson

    113 posts

    Damn it, knew i should have waited till .1!

  • #5 / Jul 17, 2014 2:29pm

    Wes Baker's avatar

    Wes Baker

    343 posts

    Turns out if you replace the grid fieldtype with the 2.8.1 version it fixes this bug, if you need it working asap.

    We definitely don’t recommend doing this. Instead you should take a look at this bug report for instructions on a fix.

  • #6 / Jul 17, 2014 2:35pm


    3 posts


    Thank you! I can confirm that fix works.

  • #7 / Jul 19, 2014 7:24pm


    That solution does not work. It brings another errors as you can see in the comments on the FIX page.

  • #8 / Feb 11, 2015 8:27am

    Eastwood Design

    605 posts

    I am still getting these errors on EE 2.9.2.

    Specifically when I use the MX_Cloner.  If I clone an entry that has a grid field I cannot save the sentry as I keep getting the authorize error.

    New entries seem to work fine.

    Updating MX Cloner to 1.2.7 seems to fix the error

.(JavaScript must be enabled to view this email address)

ExpressionEngine News!

#eecms, #events, #releases