ExpressionEngine CMS
Open, Free, Amazing
Brought to you by

Thread

This is an archived forum and the content is probably no longer relevant, but is provided here for posterity.

The active forums are here.

Communicate: PHP Errors

December 29, 2010 4:39pm

Subscribe [5]
  • #1 / Dec 29, 2010 4:39pm

    Krake

    72 posts

    When sending email to mailing list I get the following warnings. However, the email is sent/received.

    A PHP Error was encountered
    Severity: Warning
    Message: mail(): Policy restriction in effect. The fifth parameter is disabled on this system
    Filename: libraries/Email.php
    Line Number: 1537

    A PHP Error was encountered
    Severity: Warning
    Message: Cannot modify header information - headers already sent by (output started at [path]/codeigniter/system/core/Exceptions.php:170)
    Filename: core/Common.php
    Line Number: 405

    Version: 2.1.3 Build 20101220. Just upgraded from 1.6.9 no other probl.
    Email details: 2 emails on list, no attatchments, happens in both plain text and html emails

    Any ideas?
    -Kath

  • #2 / Dec 29, 2010 5:38pm

    Ingmar Greil's avatar

    Ingmar Greil

    29243 posts

    It sounds as though your PHP environment is running in safe mode. In that case, the fifth parameter of mail() is disabled. Ask your host about it.

  • #3 / Dec 29, 2010 6:09pm

    Krake

    72 posts

    OK, thanks. Safe mode is off but some functions are disabled: https://www.one.com/en/support/faq/what-is-php-safe-mode-and-open-basedir - would any of them cause problems on running EE, you think?

  • #4 / Dec 29, 2010 11:25pm

    John Henry Donovan's avatar

    John Henry Donovan

    12340 posts

    Krake,

    You can see on the page that you linked to that the 5th parameter in mail() is disabled so yes you will run into issues with EE sending email.

    Having open basedir set to on could also cause issue in with various aspects of functionality in EE.

    Can you check our requirements page and run our Server Wizard please?

    I am going to move this thread to the EE2.x forums for you

  • #5 / Sep 22, 2011 6:18am

    pushloop's avatar

    pushloop

    422 posts

    Hey Krake

    Dig you ever find a solution for this? I’m working with a client who is also hosted by One.com, and I have the same issue.

    Just to clearify, I ran the server wizard and it reported no issues - all lights green there!

  • #6 / Sep 22, 2011 6:25pm

    Kevin Smith's avatar

    Kevin Smith

    4784 posts

    Since this looks like it was something resolved with the host, I’ll let you two continue this conversation over in Community Help!

    AndrĂ©, if this looks like something that will need to involve our help, please don’t hesitate to let us know!

  • #7 / Sep 23, 2011 12:26pm

    Krake

    72 posts

    Hi André,
    To be honest, I had forgotten all about this issue…

    It persists although I just updated to EE 2.2.2, so I’m afraid it’s something one.com should deal with. As of right now it’s not a priority to my client, but if you happen to find a solution with the host, please give me a hint.

    -Kath

  • #8 / Apr 19, 2012 6:06am

    atelier2's avatar

    atelier2

    181 posts

    Hi, I do hope I can solve my problem with your help.
    I just checked, my host has safe mode off and open basedir on.
    Host is One.coms

    Before install, we ran the Wizard, all seemed well.

    Yet I get the message that something is wrong, I cannot send notifications to more recepients. Mail is send, though.

    What do I do now?

    Thanks for the advise.

  • #9 / Jul 30, 2014 11:16am

    flauzz

    3 posts

    Hi everybody,

    I have the same problem @one.com
    safe mode = off and open basedir = on.

    Has someone found a solution for it?

    Would be very very helpful 😊

  • #10 / Jul 31, 2014 10:35am

    flauzz

    3 posts

    Ok I found the solution for everybody who has one.com as provider.

    change the code at /system/libraries/email.php in function _send_with_mail()

    from

    if ( ! mail($this->_recipients, $this->_subject, $this->_finalbody, $this->_header_str, "-f ".$this->clean_email($this->_headers['From'])))

    to

    if ( ! mail($this->_recipients, $this->_subject, $this->_finalbody, $this->_header_str))

    because of: “// most documentation of sendmail using the “-f” flag lacks a space after it, however
      // we’ve encountered servers that seem to require it to be in place.”

.(JavaScript must be enabled to view this email address)

ExpressionEngine News!

#eecms, #events, #releases