Bug #23415 See Comments

Can’t View List of Channel Entries

Version: 3.5.14 Reporter: msunickb

Here’s the description of the issue from the user: In the CMS, when adding or editing an “Add or Edit” entry (listing), once I save the entry and am brought back to the Structure view, I am not able to click on “Edit” next to the page name to get back to the entry to edit it again. Clicking on the Edit link next to the page name just keeps you on the Structure page. I’m also not able to get to the entry to edit it through the Edit button in the CMS’s primary navigation. Only by clicking on Edit > View All and then filtering by channel can I get to the entry to edit it again.

Here’s the background, ExpressionEngine 3.5.14, Structure 4.3.2. There are a combination of pages, listings and assets on this particular site. I have not been able to replicate the issue on any other sites we’ve built using V3 and there is nothing special that I can think of about the setup of this site, which I built.

I can replicate the issue above in both Chrome and Firefox but haven’t tried other browsers. The one very interesting thing I’ve found is until you save an entry (not sure if it’s just listings or all entries) everything actually works completely fine. It’s once you save an entry the channel that entry belongs to no longer works when you click Edit either via the Edit Menu or the “Edit” link for the listing in Structure.

Here is a video of the issue happening: https://screencast.com/t/tniNkyvsp2

You’ll see the first time through I’m able to click the edit link, view the entries and edit the entry without issue. Once saved though, you cannot click the Edit link either via the Structure Listing or the EE Edit menu.

  • Have you contacted the developer of Structure? That is a third-party add-on that heavily modifies ExpressionEngine, and is not something we can help you with.

    Derek Jones
    12th January, 2018 at 5:25pm
  • I haven’t because disabling extensions (via the global variable over-ride) produces the same result through the edit menu so I assumed it was not Structure related. Should I reach out to them anyway?

    msunickb
    14th January, 2018 at 10:55pm
  • Yeah I can’t reproduce the issue, I’m guessing it may have something to do with how the entry gets saved when the add on is enabled?

    Derek Jones
    15th January, 2018 at 12:49am

You must be signed in to comment on a bug report.

ExpressionEngine News

#eecms, #events, #releases