Bug #23259 Accepted

Menu Manager : When menu list is modified, the order of the list items change.

Version: 3.5.11 Reporter: stefanos

When I reorder a drop-down menu list inside the Menu SetsEdit / Menu Set page, and I click on save menu set, all is fine, the menu list appear as I reordered it. But if I modify this list (edit menu item), adding a new list item, or modifying its name, and i save it, the order of the items change.

There is an other problem : there are many list items, sometimes when I click on a specific one, an other one appears to be set, it’s not the good one. This problems appears very often.

  • Additional data:

    If and new item is added in a a drop-down menu list, it is at the bottom of the list. So if the item name begin by the C letter, I drag and drop it to reorganize them alphabetically. But when this new item that begin by C id dropped, many of the of the other items, are no longer in the right place. The action of drag and drop an item, change the place of many of the other items.

    admin.php/admin.php?/cp/settings/menu-manager/edit-set/1

    stefanos
    30th October, 2017 at 1:00pm
  • This problems also happens when the new added item is saved. All the list is disorderly. It seems, that those disorderly items are ordered according to on their date of installation. Each time and item is added, I have to reorganise them (with Menu Sets / Edit Menu Set, page).

    stefanos
    30th October, 2017 at 1:17pm
  • Hi Stefanos,

    I’m sorry you’re running into a problem with it.

    I had trouble triggering the problem, but I just now saw it. One of my dropdowns is sorted alpha and shows correctly, but then I click ‘Edit’ and it’s out of order on the edit page! Odd, because I’m sure it wasn’t in earlier tests.

    Definitely something buggy there, we’ll look into it and reply back here once it’s nailed down.

    Robin Sowell
    01st November, 2017 at 3:02pm
  • Hi Robin,

    first I thought the problem came from one of several installed add-ons. But even in a fresh install, this problem persists. So to help other EE users who may encounter this bug, I tried to explain it.

    Good luck to solve it !!

    best,

    Stéphane

    stefanos
    01st November, 2017 at 4:45pm

You must be signed in to comment on a bug report.

ExpressionEngine News

#eecms, #events, #releases