Bug #23568 Bug Fixed

Cache_memcached driver produces php warning in php 7.2

Version: 4.1.3 Reporter: timoteus

Hi!

When turnung on the template-cache and using memcached as the driver, on the first pageload the driver shows a php warning:

count(): Parameter must be an array or an object that implements Countable ee/legacy/libraries/Cache/drivers/Cache_memcached.php, line 151

  • Thank you timoteus; this is fixed for the next release and a patch was added to the Solution tab above.

    Derek Jones
    13th April, 2018 at 10:58am

You must be signed in to comment on a bug report.

  • In system/ee/legacy/libraries/Cache/drivers/Cache_memcached.php line 151 change:

    if (count($stored) !== 3)

    to:

    if ($stored == FALSE OR count($stored) !== 3)
.(JavaScript must be enabled to view this email address)

ExpressionEngine News!

#eecms, #events, #releases