Bug #23414 Duplicate

“Exception Caught” when clicking “Publishing Settings” under user profile in control panel

Version: 4.0.5 Reporter: Matthew81

Steps to replicate:

  • Click logged-in name at top right of control panel, click “My Profile”
  • On the My Profile page, click “Publishing Settings” in the left-hand menu

For me, this gives the following error:

Exception Caught
SQLSTATE[42S02]: Base table or view not found: 1146 Table 'REDACTED.exp_rte_toolsets' doesn't exist:
SELECT rte_m_Toolset_rte_toolsets.toolset_id as rte_m_Toolset__toolset_id, rte_m_Toolset_rte_toolsets.member_id as rte_m_Toolset__member_id, rte_m_Toolset_rte_toolsets.name as rte_m_Toolset__name, rte_m_Toolset_rte_toolsets.tools as rte_m_Toolset__tools, rte_m_Toolset_rte_toolsets.enabled as rte_m_Toolset__enabled FROM (`exp_rte_toolsets` as rte_m_Toolset_rte_toolsets) LIMIT 18446744073709551615
ee/legacy/database/drivers/mysqli/mysqli_connection.php:116

Stack Trace: Please include when reporting this error
#0 ee/legacy/database/drivers/mysqli/mysqli_driver.php(111): CI_DB_mysqli_connection->query('SELECT rte_m_To...')
#1 ee/legacy/database/DB_driver.php(269): CI_DB_mysqli_driver->_execute('SELECT rte_m_To...')
#2 ee/legacy/database/DB_driver.php(179): CI_DB_driver->simple_query('SELECT rte_m_To...')
#3 ee/legacy/database/DB_active_rec.php(1137): CI_DB_driver->query('SELECT rte_m_To...')
#4 ee/EllisLab/ExpressionEngine/Service/Model/Query/Select.php(48): CI_DB_active_record->get()
#5 ee/EllisLab/ExpressionEngine/Service/Model/DataStore.php(281): EllisLab\ExpressionEngine\Service\Model\Query\Select->run()
#6 ee/EllisLab/ExpressionEngine/Service/Model/DataStore.php(227): EllisLab\ExpressionEngine\Service\Model\DataStore->runQuery('Select', Object(EllisLab\ExpressionEngine\Service\Model\Query\Builder))
#7 ee/EllisLab/ExpressionEngine/Service/Model/Query/Builder.php(143): EllisLab\ExpressionEngine\Service\Model\DataStore->selectQuery(Object(EllisLab\ExpressionEngine\Service\Model\Query\Builder))
#8 ee/EllisLab/ExpressionEngine/Service/Model/Query/Builder.php(62): EllisLab\ExpressionEngine\Service\Model\Query\Builder->fetch()
#9 ee/EllisLab/ExpressionEngine/Controller/Members/Profile/Publishing.php(59): EllisLab\ExpressionEngine\Service\Model\Query\Builder->all()
#10 [internal function]: EllisLab\ExpressionEngine\Controller\Members\Profile\Publishing->index()
#11 ee/EllisLab/ExpressionEngine/Core/Core.php(229): call_user_func_array(Array, Array)
#12 ee/EllisLab/ExpressionEngine/Core/Core.php(109): EllisLab\ExpressionEngine\Core\Core->runController(Array)
#13 ee/EllisLab/ExpressionEngine/Boot/boot.php(146): EllisLab\ExpressionEngine\Core\Core->run(Object(EllisLab\ExpressionEngine\Core\Request))
#14 public_html/admin.php(147): require_once('...')
#14 public_html/admin.php(147): require_once('...')

You must be signed in to comment on a bug report.

ExpressionEngine News

#eecms, #events, #releases