Bug #23407 Bug Fixed

Default public Member List page displays error

Version: 4.0.4 Reporter: Hop Studios

https://example.com/member/memberlist

I’m logged in as a superadmin. This is a fresh install.

Exception Caught
SQLSTATE[42000]: Syntax error or access violation: 1064 You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'desc' at line 6:
SELECT m.member_id, m.username, m.screen_name, m.email, m.join_date, m.last_visit, m.last_activity, m.last_entry_date, m.last_comment_date, m.last_forum_post_date, m.total_entries, m.total_comments, m.total_forum_topics, m.total_forum_posts, m.language, m.timezone, m.accept_user_email, m.avatar_filename, m.avatar_width, m.avatar_height, (m.total_forum_topics + m.total_forum_posts) AS total_posts, g.group_title as member_group FROM exp_members m LEFT JOIN exp_member_groups g ON g.group_id = m.group_id WHERE g.group_id != '3' AND g.group_id != '4' AND g.site_id = '1' AND g.include_in_memberlist = 'y' AND g.group_id != '2' ORDER BY m. desc
ee/legacy/database/drivers/mysqli/mysqli_connection.php:116

Stack Trace: Please include when reporting this error
#0 ee/legacy/database/drivers/mysqli/mysqli_driver.php(111): CI_DB_mysqli_connection->query('SELECT m.member...')
#1 ee/legacy/database/DB_driver.php(269): CI_DB_mysqli_driver->_execute('SELECT m.member...')
#2 ee/legacy/database/DB_driver.php(179): CI_DB_driver->simple_query('SELECT m.member...')
#3 ee/EllisLab/Addons/member/mod.member_memberlist.php(538): CI_DB_driver->query('SELECT m.member...')
#4 ee/EllisLab/Addons/member/mod.member.php(1525): Member_memberlist->memberlist()
#5 ee/EllisLab/Addons/member/mod.member.php(366): Member->memberlist()
#6 ee/legacy/libraries/Core.php(581): Member->manager()
#7 ee/legacy/controllers/ee.php(62): EE_Core->generate_page()
#8 [internal function]: EE->index()
#9 ee/EllisLab/ExpressionEngine/Core/Core.php(229): call_user_func_array(Array, Array)
#10 ee/EllisLab/ExpressionEngine/Core/Core.php(109): EllisLab\ExpressionEngine\Core\Core->runController(Array)
#11 ee/EllisLab/ExpressionEngine/Boot/boot.php(146): EllisLab\ExpressionEngine\Core\Core->run(Object(EllisLab\ExpressionEngine\Core\Request))
#12 index.php(172): require_once('...')
#12 index.php(172): require_once('...')

Here’s what my sorting was set to: https://www.dropbox.com/s/zt7zrzt1im7ss93/Screenshot%202018-01-10%2016.25.58.png?dl=0

  • Nobody has said anything yet.

You must be signed in to comment on a bug report.

ExpressionEngine News

#eecms, #events, #releases