Bug #23249 Accepted

avatar library not showing up

Version: 3.5.11 Reporter: BBDOKC

When I add a folder to the avatar path eg: “/public_html/images/avatars/” The folder for that library does not show in the selection process. “default” is still the only link displayed. I have done this in prior versions by simply dropping my library folder in the path and then selecting them from the member profile edit CP area. Has this changed?

  • The structure of the avatar folder did change from v2 to v3.

    User uploaded avatars go in images/avatars/ while the shared ‘default’ images go in images/avatars/default/.

    So if you want to add more shared avatar options for folks to select from, you’ll need to drop them in the default folder.

    Does that get it working like you expected?

    Robin Sowell
    17th October, 2017 at 3:47pm
  • No. Unfortunately not. Before, I had multiple “libraries” they could select from. So I would drop the folders into the same location as default. Say something like :

    /images/avatars/default/ /images/avatars/set1/ /images/avatars/set2/ etc…

    These then showed up as link options to select from like default. Is this not the case or possible any longer?

    BBDOKC
    17th October, 2017 at 4:07pm
  • OK @Robin,

    I installed the forum module since that is primarily what I was going to use avatars for. Oddly enough, the forum module shows the multiple folders in the selection options. This is how EE used to handle the same. The primary issue I have now is that the member profiles do not correlate with each other. If I select an avatar in the EE member edit CP it does not show up in the forum module. I still have to go into the forum navigate to >Your Control Panel > Edit Avatar > Browse our Avatar Library. This provides the multiple links as expected. at which time I have to go select another avatar which can be different that the one I have already selected in the member CP.

    Is there not a way to get these to work together like the rest of the member profile options?

    BBDOKC
    18th October, 2017 at 1:38pm
  • Sorry… Forgot to add that the memberships will also be for blog usage so having to choose multiple times and locations becomes confusing.

    BBDOKC
    18th October, 2017 at 1:39pm
  • Testing further… This is the full scope of the functionality and disconnect.

    1) Add a folder under avatars in the EE folder structure. eg: /public_html/images/avatars/ – ../avatars/default/ (default EE avatars) – ../avatars/option2/ (optional set of avatars)

    2) Go to “Members / Personal Settings” in EE CP – Folder Not Shown

    3) Go to Forum > Your Control Panel > Edit Avatar – Folder Shown for Option2

    As you can see, the library folder is shown

    4) Click on Option2 link and select avatar from optional folder set. – Forum allows selection from option2 location

    5) Return to EE CP “Members / Personal Settings” – EE CP shows selection from option2 location

    Now delete the avatar. (Doesn’t matter from where)

    The only solution I see (for now) is simply not allowing profile modification via EE like I currently have. I will only allow management via forum section. The problem is that this is a multi-level membership site and the design was not for all to have access to the forum. Some were only allowed access to the blog area and were able to comment there. The issue is the confusion it created for the testers when they were allowed different options in the forum than what they had in their initial setup.

    Ideally, it would be nice (maybe a feature request) to allow multiple folders in EE like that in the forum which could even be controlled in the “Member Group” settings for allowed avatar folders. This would at least allow a more fluid feel to the process.

    BBDOKC
    18th October, 2017 at 2:09pm
  • Images did not show in markdown code above. Trying again:

    2

    3

    4

    5

    BBDOKC
    18th October, 2017 at 2:15pm
  • Markdown not working. Use these links

    https://ibb.co/cKpDFm https://ibb.co/j9T7am https://ibb.co/nvBAvm https://ibb.co/hJQg1R

    BBDOKC
    18th October, 2017 at 2:16pm
  • I really appreciate all of the screen caps- I had to look a couple of times before it really sank in what was happening.

    The fact the CP and the frontend work differently is definitely a bug. They should be consistent.

    I didn’t actually expect the second folder to work, but since it does on the frontend and we have to fix it to be consistent one way or the other, I’ll definitely see if there’s any unforseen problem using the frontend manager approach universally.

    Robin Sowell
    25th October, 2017 at 6:35pm
  • That would be great Robin. I think that would add a level of control that could be useful. wink

    Thanks again.

    BBDOKC
    25th October, 2017 at 10:40pm

You must be signed in to comment on a bug report.

ExpressionEngine News

#eecms, #events, #releases