Bug #23216 See Comments

Error While Installing 3.5.11

Version: 3.5.11 Reporter: Gabi

I bought a new Expression Engine license and I’m trying to install it on a web host. Yes they have latest PHP installed.

I urgently need to setup a new website and I’m getting this error.

Error While Installing 3.5.11

Oops, there was an error

The required Fileinfo PHP extension is not currently enabled.

I talked to the web host and they don’t want to know about it. They say you should fix your program. They run C Panel and I can only do what is available in C Panel.

What do I do now? We purchased two other licenses from you in the past and use older version of EE on those two sites. I tried installing one on those older versions on this host and it looks like this would work. The only problem is EE installation is asking for EE version and license and we already used those old licences on other sites.

I’m more then happy to use your older EE version. Can I use your older version with the license I purchased yesterday (6398-2045-0586-0512)?

I don have much time. Please let me know if I can use your older EE version with the license I purchased yesterday.

Regards

Gabi

  • Hi Gabi, sorry you’re having issues! The bug tracker however is not for technical or license support, please send an email to support@expressionengine.com or put in a support ticket with these types of issues.

    The Fileinfo extension is a requirement to run ExpressionEngine, and is a default extension of PHP since 5.3.0 that must be explicitly disabled to not be available. The server compatibility wizard also tests for it and will alert you if an environment is incompatible with ExpressionEngine. I would recommend running this first so that you know all of the settings you may need to change to bring your hosting environment up to speed.

    I believe in cPanel you can go to “Select PHP Version”, and in addition to selecting PHP 7.0+, you should have a list of PHP extensions as checkboxes. Find fileinfoin that list, select it, and save. If for some reason your host has disabled this ability and refuses to enable it for you, you will not be able to run ExpressionEngine in that environment. Older versions that you refer to that are not making use of this native PHP extension are insecure, and it’s a security risk to run on a hosting environment that is not using an up-to-date LAMP stack that makes these available to a PHP application.

    Hope that helps and please email support if you have any further questions!

    Derek Jones
    01st September, 2017 at 9:44am

You must be signed in to comment on a bug report.

ExpressionEngine News

#eecms, #events, #releases