Bug #23195 Fix is in Upcoming Release

Third party addon field type installed but not removed when removing addon

Version: 3.5.9 Reporter: TJ Draper

One of my add-ons has a field type declared in addon.setup and it gets installed properly but does not get removed when removing the add-on. I’m not doing any custom install or uninstall routines on the field type.

EE version is actually 3.5.10 but don’t see that listed.

  • TJ, is it possible to zip the whole thing up and send it over to me at robin.sowell@expressionengine.com? I think that’s the fastest way to see what’s up.

    Robin Sowell
    07th August, 2017 at 10:57am
  • Send via Google Drive (Gmail won’t let me send zip files anymore because of “security”)

    TJ Draper
    08th August, 2017 at 1:25pm
  • Sweet- thanks for the help, TJ. Definitely a quirky bug that only happened due to the name of the ft file.

    We’ve got a fix in for the next release and I put the patch in the solution tab.

    If you run into any problems with it, let me know.

    Robin Sowell
    09th August, 2017 at 12:37pm

You must be signed in to comment on a bug report.

  • It only happens if there is no fieldtype with the ‘standard’ name for the file. So folder is test, module is mod.test.php but fieltype is ft.test_file.php.

    You can patch by editing system/Ellislab/ExpresisonEngine/Controller/Addons/Addons.php around line 836

    if ( ! empty($fieldtype) && $fieldtype['installed'] === TRUE)
    change to 
    if ( ! empty($fieldtype))

ExpressionEngine News

#eecms, #events, #releases