Bug #23011 Duplicate

Major Field Issues in 3.5.2

Version: 3.5.2 Reporter: AnthonyP

After upgrading from 3.3.3 or even a fresh install to 3.5.2 When creating a channel grid field with a multi select list it generates the following errors:

Exception Caught

SQLSTATE[42S22]: Column not found: 1054 Unknown column 'field_id_' in 'field list':
SELECT `field_id_` FROM (`exp_channel_data`) WHERE `channel_id` IS NULL

ee/legacy/database/drivers/mysqli/mysqli_connection.php:122



#0 ee/legacy/database/drivers/mysqli/mysqli_driver.php(137): CI_DB_mysqli_connection->query('SELECT `field_i...')
#1 ee/legacy/database/DB_driver.php(297): CI_DB_mysqli_driver->_execute('SELECT `field_i...')
#2 ee/legacy/database/DB_driver.php(203): CI_DB_driver->simple_query('SELECT `field_i...')
#3 ee/legacy/database/DB_active_rec.php(1206): CI_DB_driver->query('SELECT `field_i...')
#4 ee/legacy/fieldtypes/EE_Fieldtype.php(928): CI_DB_active_record->get('channel_data')
#5 ee/EllisLab/Addons/multi_select/ft.multi_select.php(82): EE_Fieldtype->_get_field_options('')
#6 ee/EllisLab/Addons/multi_select/ft.multi_select.php(110): Multi_select_ft->display_field('')
#7 [internal function]: Multi_select_ft->grid_display_field('')
#8 ee/legacy/libraries/api/Api_channel_fields.php(409): call_user_func_array(Array, Array)
#9 ee/legacy/libraries/Grid_parser.php(700): Api_channel_fields->apply('grid_display_fi...', Array)
#10 ee/EllisLab/Addons/grid/libraries/Grid_lib.php(203): Grid_parser->call('display_field', '')
#11 ee/EllisLab/Addons/grid/libraries/Grid_lib.php(88): Grid_lib->_publish_field_cell(Array)
#12 ee/EllisLab/Addons/grid/ft.grid.php(158): Grid_lib->display_field(Object(EllisLab\ExpressionEngine\Library\CP\GridInput), NULL)
#13 ee/legacy/fieldtypes/EE_Fieldtype.php(359): Grid_ft->display_field(NULL)
#14 [internal function]: EE_Fieldtype->display_publish_field(NULL)
#15 ee/legacy/libraries/api/Api_channel_fields.php(409): call_user_func_array(Array, Array)
#16 ee/EllisLab/ExpressionEngine/Model/Content/FieldFacade.php(205): Api_channel_fields->apply('display_publish...', Array)
#17 ee/EllisLab/ExpressionEngine/Model/Content/Display/FieldDisplay.php(59): EllisLab\ExpressionEngine\Model\Content\FieldFacade->getForm()
#18 ee/EllisLab/ExpressionEngine/View/publish/entry.php(146): EllisLab\ExpressionEngine\Model\Content\Display\FieldDisplay->getForm()
#19 ee/EllisLab/ExpressionEngine/Service/View/View.php(145): include('...')
#20 ee/EllisLab/ExpressionEngine/Service/View/View.php(110): EllisLab\ExpressionEngine\Service\View\View->parse('...', Array)
#21 ee/legacy/libraries/View.php(51): EllisLab\ExpressionEngine\Service\View\View->render(Array)
#22 ee/legacy/libraries/Cp.php(241): View->render('publish/entry', Array, false)
#23 ee/EllisLab/ExpressionEngine/Controller/Publish/Publish.php(272): Cp->render('publish/entry', Array)
#24 [internal function]: EllisLab\ExpressionEngine\Controller\Publish\Publish->create('1')
#25 ee/EllisLab/ExpressionEngine/Core/Core.php(189): call_user_func_array(Array, Array)
#26 ee/EllisLab/ExpressionEngine/Core/Core.php(94): EllisLab\ExpressionEngine\Core\Core->runController(Array)
#27 ee/EllisLab/ExpressionEngine/Boot/boot.php(151): EllisLab\ExpressionEngine\Core\Core->run(Object(EllisLab\ExpressionEngine\Core\Request))
#28 admin.php(143): require_once('...')
#28 admin.php(143): require_once('...')

You must be signed in to comment on a bug report.

ExpressionEngine News

#eecms, #events, #releases