Bug #22868 Accepted

Forum post markup output is wrong

Version: 3.4.7 Reporter: Rob (bluedreamer)

Looking at the EE forums, if I add a code snippet like

{path='blog/index'}

It outputs https://expressionengine.com/blog

  • Hi Rob,

    That path output looks correct to me. What are you expecting to be output?

    Kevin Cupp
    04th January, 2017 at 1:44pm
  • It is in the bug tracker but in the forums adding code snippets goes a bit wonky, see my reply at https://expressionengine.com/?ACT=265&reply=ALSPkot+uh6GR6lqgEIg9KmIIhaDWYM8N0wuIfZo/xT+MIOeS1oAjnCIh5FLXgrF8zIyePnbeCjjGOPv0+S2oA==&return=E1P8V30HVxpihLJKWT2x3MGtr4ZOs76qnBOhQjU9EUk=

    Code entered was

    <ul>
    {categories}
    <li><a href="http://{path=blog/index}">{category_name}</a></li>
    {/categories}
    </ul>

    Yet the href value outputs as https://expressionengine.com/blog/index

    Rob (bluedreamer)
    04th January, 2017 at 2:08pm
  • In fact see how the code snippet above pumps out “http://” as well when it wasn’t in my code snippet!

    Rob (bluedreamer)
    04th January, 2017 at 2:09pm
  • Testing:

    <ul>
    {categories}
    <li><a href="http://{path=blog/index}">{category_name}</a></li>
    {/categories}
    </ul>
    Kevin Cupp
    04th January, 2017 at 2:29pm
  • Interesting! Trying to isolate:

    <a href="{path='blog/index'}">
    Kevin Cupp
    04th January, 2017 at 2:30pm
  • <li><a href="http://{path=blog/index}">{category_name}</a></li>
    {categories}<li><a href="http://{path=blog/index}">{category_name}</a></li>{/categories}
    <ul>{categories}<li><a href="http://{path=blog/index}">{category_name}</a></li>{/categories}</ul>
    Kevin Cupp
    04th January, 2017 at 2:31pm
  • <a href="http://{path=blog/index}">test</a>
    Kevin Cupp
    04th January, 2017 at 2:32pm
  • Heh sorry for all the comments, Rob. Looks like it does it if we put it inside a complete anchor link tag. We’ll look into it!

    Kevin Cupp
    04th January, 2017 at 2:33pm
  • No problem, gotta test stuff!

    Rob (bluedreamer)
    04th January, 2017 at 4:18pm

You must be signed in to comment on a bug report.

ExpressionEngine News

#eecms, #events, #releases