Bug #22079 Clarification Requested

Install with Default Theme

Version: 3.4.2 Reporter: Denik

When I try install core version of EE v3.4.2 with checked yes “Install default theme?”, I see next error:

SQLSTATE[42S01]: Base table or view already exists: 1050 Table 'exp_channel_grid_field_4' already exists:
CREATE TABLE `exp_channel_grid_field_4` ( `row_id` int(10) UNSIGNED AUTO_INCREMENT, `entry_id` int(10) UNSIGNED, `row_order` int(10) UNSIGNED, PRIMARY KEY `row_id` (`row_id`), KEY `entry_id` (`entry_id`) ) DEFAULT CHARACTER SET utf8 COLLATE utf8_unicode_ci ENGINE=InnoDB;

ee/legacy/database/drivers/mysqli/mysqli_connection.php:119

ScreenShot: http://prntscr.com/cfxgtj

  • oh… I trying to fix this error, but I got new error: http://prntscr.com/cfzfeb

    SQLSTATE[42S22]: Column not found: 1054 Unknown column 'col_id_6' in 'field list':
    INSERT INTO `exp_channel_grid_field_7` (`col_id_17`, `col_id_18`, `col_id_6`, `col_id_7`, `col_id_8`, `entry_id`, `row_order`) VALUES (NULL,NULL,'{filedir_7}common.jpg','Dharmafrog, 2014','right','2',0)

    about main problem… I think it problem in ee()->db->list_tables() and ee()->db->list_fields() methods because this methods use data_cache variable… but it is wrong for installation process

    Denik
    09th September, 2016 at 8:01am
  • Hi Denik, I think it’s the same issue reported here. Can you try the bug patch posted there and see if it takes care of it for you?

    Robin Sowell
    07th October, 2016 at 2:49pm

You must be signed in to comment on a bug report.

ExpressionEngine News

#eecms, #events, #releases