Thread

Unable to load requested class: template

November 23, 2017 12:47am

Subscribe [2]
  • #1 / Nov 23, 2017 12:47am

    designstation

    41 posts

    Hi there,

    I’ve had quite a few ExpressionEngine installs over the years, but this is an issue I’ve never seen before. I’m just in the process of getting a new website set up on ExpressionEngine, and after setting up a template group for the homepage and pasting in my code, I get this error when I try to view the page in a browser:

    Error: Unable to load the requested class: template

    I’ve checked permissions to a few directories but as far as I can tell it’s not related to that.

    If you’ve ever had a similar issue, I’d love to hear how you resolved it!

    Thank you!

  • #2 / Nov 25, 2017 4:23pm

    designstation

    41 posts

    Hi there,

    Unfortunately the code in the template isn’t the issue — it doesn’t matter if the template contains EE code or just generic HTML with no EE code in it whatsoever… that error comes up. I’ve tried re-uploading ExpressionEngine but still see the error.

  • #3 / Dec 06, 2017 9:17am

    Derek Jones's avatar

    Derek Jones

    7176 posts

    It’s possible that you have corrupted files, or permissions on them as such that the web server and PHP cannot read them. Is this a local or a managed installation? If managed, where? And finally, what version of ExpressionEngine?

  • #4 / Dec 06, 2017 1:09pm

    designstation

    41 posts

    Hi Derek,

    Turns out that it’s hosted through GoDaddy (which I didn’t know when I did the original post — I thought it was through a local company). It’s actually become weirder since my original post as now I can’t even sign in to EE… the Control Panel just loads as blank. GoDaddy is in the process of moving the site between accounts, after which I’ll be able to dig into this a little more since I won’t be dealing with a third party.

    I don’t believe corrupted files were the issue, or shouldn’t have been, as I tried replacing almost all of the EE install a few times. One example of just how strange things had become: cat.php was being deleted by the server immediately after upload as malware. This happened suddenly… one day I was able to access Categories through the Control Panel, and then the next day the cat.php file was being removed by the server.

    I’ll report back once the transfer is completed, but right now I have no idea what problem is going to pop up next!

    The version I’m (trying) to use is 3.5.12.

ExpressionEngine News

#eecms, #events, #releases