Thread

unable to change personal settings

August 01, 2017 11:00am

Subscribe [4]
  • #1 / Aug 01, 2017 11:00am

    Huibc

    5 posts

    A logged in user can see his personal data and should normally be able to change them. On the site we developed, this does not work. One also receives the reaction: “The action you have requested is invalid.” Are there somewhere permissions to be set or what may be the problem?

    EE 2.7.2

  • #2 / Aug 06, 2017 9:18am

    Derek Jones's avatar

    Derek Jones

    7176 posts

    It sounds like you do not have the member module installed, or the third-party module if you’re using an add-on for member management. Sometimes this happens when someone updates the site and downloads the free Core version by mistake. I would recommend re-downloading the latest v2 release and performing an update. This will both correct any issues you may be experiencing from a bad download/deployment as well as add four years worth of bug and security fixes.

  • #3 / Aug 08, 2017 12:07pm

    Huibc

    5 posts

    Thanks for your comment. But the member module is installed, I checked it. Also we have some 130 members divided in 6 groups and some 4 “regional webmasters”. We use AC Memberlist for producing a listing of the member info and this works fine. So I think that it’s not in the direction of a missing member module that one should look for a solution.

  • #4 / Aug 08, 2017 12:22pm

    Derek Jones's avatar

    Derek Jones

    7176 posts

    What is the URL the browser is submitting this form to when you get this error? And copy the contents of the exp_actions table here as well, in Developer > Utilities > SQL Manager.

  • #5 / Aug 09, 2017 5:22am

    Huibc

    5 posts

    The form is called from the page: http://www.seniorconsultantsvlaanderen.be/index.php/member/edit_userpass The form starts with: <form method=”post” action=”http://www.seniorconsultantsvlaanderen.be/index.php/member/update_userpass”>

    SQL Query

    select * from exp_actions

    Total Results: 28

    action_id            class method      srf_exempt
    
    1 Comment      insert_new_comment    0
    2 Comment_mcp    delete_comment_notification  0
    3 Comment       comment_subscribe     0
    4 Comment       edit_comment      0
    5 Email       send_email        0
    6 Search     do_search        0
    7 Channel  submit_entry  0
    8 Channel  filemanager_endpoint  0
    9 Channel  smiley_pop  0
    10 Member  registration_form  0
    11 Member  register_member  0
    12 Member  activate_member  0
    13 Member  member_login  0
    14 Member  member_logout  0
    15 Member  send_reset_token  0
    16 Member  process_reset_password  0
    17 Member  send_member_email  0
    18 Member  update_un_pw  0
    19 Member  member_search  0
    20 Member  member_delete  0
    21 Rte  get_js  0
    25 Importer  ajax_connnection_test  0
    26 Importer  cron_import  0
    27 Importer  batch_import  0
    28 Importer  import_statistics  0
    29 Channel_images  channel_images_router  0
    30 Channel_images  locked_image_url  0
    31 Channel_images  simple_image_url  0

    Strangely, at the bottom of the page it is said : ‘ExpressionEngine is up to date (2.7.2)’. This is not correct ,although ‘Check for updates’ is flagged in the general configuration.

    Thanks in advance, Hubert

  • #6 / Aug 09, 2017 9:28am

    Derek Jones's avatar

    Derek Jones

    7176 posts

    Ok on that version it’s possible that it’s a CSRF token issue; please update to the latest version of v2 and if you are still experiencing the issue, you may contact support to diagnose the issue on your server.

  • #7 / Aug 09, 2017 9:42am

    Huibc

    5 posts

    Thanks for your interest! Our website developer is on holiday until 8/21rst. An update is only possible after that date.

    Sincerely, Hubert

ExpressionEngine News

#eecms, #events, #releases