Thread

white screen after upgrade, need help!

April 26, 2017 9:19am

Subscribe [3]
  • #1 / Apr 26, 2017 9:19am

    rokker's avatar

    rokker

    154 posts

    just went through the steps of upgrading EE 2.11 to EE 3.5.6 (after a successful upgrade from 2.x to 2.11)

    now i get white screen when trying to access admin.php to finish upgrade.

    Stuck. help. please.

  • #2 / Apr 26, 2017 12:10pm

    Derek Jones's avatar

    Derek Jones

    7176 posts

    Did you have add-ons in your installation, and if so, did you replace them all with v3 compatible versions?

  • #3 / Apr 26, 2017 11:16pm

    rokker's avatar

    rokker

    154 posts

    for an unknown reason, the ftp program did not load all files during the initial upload. it seemed the missing files were random and scattered. i scrapped the install and started over and it worked fine.

    i did change to Filezilla from FTP Voyager, and switched from FTP to SFTP per my host suggestion

  • #4 / Apr 27, 2017 12:20pm

    Derek Jones's avatar

    Derek Jones

    7176 posts

    Ok glad you discovered the problem!

  • #5 / Apr 28, 2017 6:56pm

    xynergy_inc

    7 posts

    I’m getting this now too… trying to upgrade from 2.11.6 to 3.5.6. I’ve removed all modules/plugins that aren’t compatible with EE3, checked to make sure all the files are present on the server before attempting the upgrade and strictly followed the instructions as per https://docs.expressionengine.com/latest/installation/upgrade_from_2.x.html but I get a white screen every time.

    Any ideas what causes this? If I go back to the Install screen after the whitescreen, it tells me I’m upgrading from version 3.0.0 so it looks like it’s that particular upgrade that’s causing this, but I don’t know how to troubleshoot.

    Any advice appreciated.

  • #6 / Apr 28, 2017 6:59pm

    Derek Jones's avatar

    Derek Jones

    7176 posts

    Here is some general good advice on discovering the source of white screens (which are typically hidden fatal PHP errors): https://gist.github.com/litzinger/5598641

  • #7 / May 01, 2017 12:03pm

    xynergy_inc

    7 posts

    Thanks Derek, I did try the basic method and still was getting WSOD but I think I may have figured out at least why I wasn’t seeing the errors. We set AuthType Basic in our .htaccess for DEV sites to keep Google from indexing them and removing that authentication has at least helped show me the errors.

    The error I’m getting appears to during the automatic combining of the config.php and database.php files. I get up to EE3.4.1 and then get a syntax error in the newly amended config.php… opening it up the first few lines look like this:

    config[‘database’] = array (

    $config[‘enable_devlog_alerts’] = ‘n’; ‘expressionengine’ => array ( ‘hostname’ => ‘localhost’,

    which is clearly wrong. I double-checked the syntax in the original two files and all looks good, so I guess I’ll try manually combining them before running the upgrade process.

    Have you ever run into syntax errors with the automatically combined config.php?

    Thanks, Justin

  • #8 / May 01, 2017 12:52pm

    Derek Jones's avatar

    Derek Jones

    7176 posts

    No, we haven’t seen that, and that occurs in the first step onto 3.0.0, so I’d expect if that were the issue that it would present itself well before then. 3.4.2 does add that enable_devlog_alerts key, though not sure why it’s trying to insert it into the db array. If re-running the update does not fix it, I would recommend opening system/ee/installer/updates and removing all of the files from ud_3_04_02.php and onward. That will take you to 3.4.1 and stop. At that point, you could share your config file’s contents (make sure to remove any db passwords and your encryption key before sharing) and maybe we can spot something.

  • #9 / May 01, 2017 1:06pm

    xynergy_inc

    7 posts

    Thanks for your input Derek. Just moving the enable_devlog_alerts key to outside the DB array and ‘continuing’ the upgrade seemed to work - no idea why that was happening, but it was happening consistently. Just fighting through individual plugin update errors now. Thanks for your help.

  • #10 / May 01, 2017 1:16pm

    Derek Jones's avatar

    Derek Jones

    7176 posts

    Odd, but glad you got past it!

ExpressionEngine News

#eecms, #events, #releases