Thread

2.8 System Requirements

February 08, 2014 11:10am

Subscribe [4]
  • #1 / Feb 08, 2014 11:10am

    Rob Sanchez's avatar

    Rob Sanchez

    335 posts

    Is this blog post still accurate? http://ellislab.com/blog/entry/changing-php-requirements

    The requirements doc for 2.8 still indicates PHP 5.2.

  • #2 / Feb 09, 2014 12:12pm

    Derek Jones's avatar

    Derek Jones

    6922 posts

    Yes, thanks for that catch Rob. Fixed for the next build.

  • #3 / Feb 10, 2014 10:02am

    Rob Sanchez's avatar

    Rob Sanchez

    335 posts

    Can you share any insight into why 5.3.10 specifically is the required 5.3 version? Are there any 5.3 specific changes in 2.8?

    Will we see composer usage in the future? smile

  • #4 / Feb 10, 2014 11:05am

    Kevin Cupp's avatar

    Kevin Cupp

    637 posts

    Hi Rob,

    Sorry, Derek was mistaken. The blog post says “the next feature release following ExpressionEngine 2.8,” so we’re still requiring at least 5.2.4 for 2.8.

    As for why, mostly for the reasons listed in the blog post, there’s ways we’d like to structure our code that we can’t do quite yet, as well as some nifty PHP APIs we’re missing out on. And 5.3.10 was chosen I think due to a bug that was fixed in that version, we like to make sure we choose a pretty stable version for our minimum requirement.

    Kevin

  • #5 / Feb 10, 2014 11:06am

    Rob Sanchez's avatar

    Rob Sanchez

    335 posts

    Thanks for the clarification!

  • #6 / Feb 10, 2014 11:55am

    Derek Jones's avatar

    Derek Jones

    6922 posts

    Man, I can’t sneak anything past the engineers. ><

ExpressionEngine News

#eecms, #events, #releases