ExpressionEngine CMS
Open, Free, Amazing

Thread

This is an archived forum and the content is probably no longer relevant, but is provided here for posterity.

The active forums are here.

Unable to Create a Channel Field in existing channel

September 02, 2013 11:45am

Subscribe [14]
  • #16 / Dec 03, 2013 7:07pm

    Victor Paredes

    7 posts

    I, too, am having this problem. Using P+T Matrix until this gets resolved.

  • #17 / Dec 05, 2013 2:12pm

    Kevin Cupp's avatar

    Kevin Cupp

    791 posts

    Like Grid, the shiny new first-party add-on?  😊

    No, third-party.

  • #18 / Dec 05, 2013 8:24pm

    kstatham

    52 posts

    Disabling Grid worked for me… allowed me to create a new field.

    However, I ran into the error again when trying to create a new Low Variable.

  • #19 / Dec 18, 2013 2:58pm

    design132

    101 posts

    Yup me too directly after upgrading to 2.7.3.  EE—please any word on this… this issue was reported back on DEC 4th!

  • #20 / Dec 18, 2013 3:01pm

    OutofControl's avatar

    OutofControl

    164 posts

    As asked in this reply http://ellislab.com/forums/viewreply/1058852/ do you still get the error when all other add-ons are disabled? So only stock add-ons with grid enabled.

    Ellislab is saying that this is a conflict between grid and other add-ons that aren’t managing package paths correctly.

    At least, that is my understanding.

  • #21 / Dec 18, 2013 3:25pm

    design132

    101 posts

    Hmm, if I uninstall grid from fieldtypes and it removes any associated data—what would that do to my system?  Am I going to lose any information?  I don’t evne know what that grid fieldype does or is.

  • #22 / Dec 21, 2013 12:22pm

    matthew3222

    1 posts

    I, too, am having this problem. Using P+T Matrix until this gets resolved.

    I have the same situation with you.

  • #23 / Dec 21, 2013 12:52pm

    design132

    101 posts

    I just had to downgrade my installation of EE because this bug wasn’t being taken care of by EE at all.  Hopefully it will in the near future.

  • #24 / Jan 15, 2014 11:40am

    Robin Sowell's avatar

    Robin Sowell

    13165 posts

    Just a quick note- if you’re sure something is a bug, don’t hesitate to post it to the Bug tracker.  In this case, it’s not a bug in EE- it looks like some addon is probably using add_package_path() to set the path (which they shouldn’t need to) and the not setting it back.  So anything AFTER that- now has the wrong path and is looking in the wrong place if it needs to load a view or such.

    In other words- you need to identify the third party add-on that’s breaking things and fix that.

    See here for a discussion and example.

  • #25 / Jan 15, 2014 12:00pm

    OutofControl's avatar

    OutofControl

    164 posts

    Thanks Robin, seeing this post I grep’d all my third party add-ons and found that 8 are using add_package_path(). I haven’t tested if they set the path back or not, but as you say, they should not be using it in the first place?

    Cartthrob
    CT Admin
    mithra62:EE_debug_toolbar
    DevDemon_Forms
    Solspace Addon Builder
    Matrix
    Playa

    It would seem use of this is fairly widespread. Hope that changes soon.

  • #26 / Jan 15, 2014 12:03pm

    Kevin Cupp's avatar

    Kevin Cupp

    791 posts

    ...they should not be using it in the first place?

    There are cases when you do need to call add_package_path(), but they need to make sure to balance it with remove_package_path() when they’re finished.

  • #27 / Jan 15, 2014 12:07pm

    OutofControl's avatar

    OutofControl

    164 posts

    Thanks Kevin,

    Carthrob and DevDemon in one of their classes uses remove_package_path(), the rest don’t appear to. Time to check for updates and contact authors I guess. Thanks for the update!

  • #28 / Aug 31, 2015 6:18pm

    I have no third-party addons installed and I have the same situation.  On both 2.7.0 and 2.10.1 though I’ve since replaced the 2.10.1 (dev) environment to try to fix without altering production.

    I even disabled absolutely everything I could including all file types, modules, plugins, etc. (all were EE/first-party).  Then I enabled Text Input field type only.  Could create a new channel field.  Enabled Grid and back to the problem.

  • #29 / Sep 01, 2015 9:46am

    Finding my issue is related to mod_security rules.  Getting it sorted out now.

.(JavaScript must be enabled to view this email address)

ExpressionEngine News!

#eecms, #events, #releases