Thread

This is an archived forum and the content is probably no longer relevant, but is provided here for posterity.

The active forums are here.

XAMPP 1.8.0 on Windows7 is slow

September 23, 2012 4:04am

Subscribe [1]
  • #1 / Sep 23, 2012 4:04am

    skunkbad's avatar

    skunkbad

    1326 posts

    I’ve installed the latest version of XAMPP on my Windows7 box because I wanted to do some testing with PHP 5.4. CodeIgniter and Community Auth seem to be running fine, yet testing revealed that any connection to the database resulted in about a 1 second lag.

    The problem ends up being that Windows is trying to resolve “localhost” when used as my connection’s hostname, which is what I’ve always used. So instead I changed the hostname in CodeIgniter’s config/database.php to “127.0.0.1”. By doing that, Windows no longer feels the need to resolve “localhost”. There was still a problem though, and that was that I had to tell MySQL (or phpMyAdmin) that it is OK for connections to come from 127.0.0.1.

    If you run the following SQL in your phpMyAdmin, you will be able to connect via 127.0.0.1:

    GRANT ALL PRIVILEGES ON *.* TO user_name@‘127.0.0.1’ IDENTIFIED BY ‘pass_word’;

    Make sure to change user_name and pass_word to your MySQL user’s real username and password, run the SQL, and restart MySQL (restarting may not be necessary). Page load times will now be normal (or at least they were for me).

    Next, phpMyAdmin itself runs painfully slow for the same reason. Open up phpMyAdmin’s config.inc.php and add the following line:

    $cfg[‘Servers’][$i][‘host’] = ‘127.0.0.1’;

    XAMPP 1.8.0 now runs just as fast as my old XAMPP installation.

    By the way, you don’t have to remove an old installation of XAMPP to run a new one on the same computer. They just can’t be running at the same time.

  • #2 / Nov 03, 2012 11:33am

    McShottie

    1 posts

    Next, phpMyAdmin itself runs painfully slow for the same reason. Open up phpMyAdmin’s config.inc.php and add the following line:

    $cfg[‘Servers’][$i][‘host’] = ‘127.0.0.1’;

    I was having a problem with Win 7, XAMPP 1.8.0 and phpMyAdmin 3.5.2, database connections were fine in my own applications but phpMyAdmin was running painfully slow. 

    This line saved me and is the only solution I’ve found that worked, thanks!

.(JavaScript must be enabled to view this email address)

ExpressionEngine News!

#eecms, #events, #releases